Back to overview
Issues with retrieval invoices in the app
Jun 06 at 01:31pm CEST
Affected services
Identity Management
Resolved
Jun 06 at 03:23pm CEST
The issue has been resolved
Affected services
Created
Jun 06 at 01:31pm CEST
We are currently experiencing issues with retrieval of invoices in the app. It is under investigation and should be resolved shortly.
Affected services