Back to overview
Deftpower portal unresponsive
Jul 09, 2025 at 08:38am UTC
Affected services
Charging Portal Backend
Resolved
Jul 09, 2025 at 08:38am UTC
Currently investigating the cause
Affected services
Resolved
Jul 09, 2025 at 08:38am UTC
Currently investigating the cause
Affected services