Back to overview
Degraded

Intermittent Unresponsiveness in Android App on Certain Devices

Aug 21 at 10:25am CEST
Affected services
Charging Portal

Resolved
Aug 25 at 04:14pm CEST

We identified the cause of the issue that was making the app intermittently unresponsive for some users on certain Android devices (including Nothing Phone, Xiaomi, and Samsung Galaxy S20 & S25).

A fix has been developed and will be rolled out shortly. Our team will continue to monitor performance closely.

Created
Aug 21 at 10:25am CEST

We are aware of an issue causing the app to become intermittently unresponsive for some users on certain Android devices, including Nothing Phone, Xiaomi, and Samsung Galaxy S20 & S25.

At this time the issue does not appear to be widespread, but our team is monitoring closely and investigating the cause. We will share updates here as we learn more.