Back to overview
EV Routing disruptancy
Sep 12, 2025 at 03:20pm UTC
Affected services
Charging Portal Backend
Resolved
Sep 12, 2025 at 03:20pm UTC
The issue has been resolved
Affected services
Resolved
Sep 12, 2025 at 03:20pm UTC
The issue has been resolved
Affected services